Internet Down

Major incident Discord Bot
2019-10-31 07:20 AWST · 45 minutes

Updates

Resolved

Bot should be booting up

November 4, 2021 · 23:24 AWST
Monitoring

SeedBot will be back up within the hour.

November 4, 2021 · 23:24 AWST

← Back